AWARE SYSTEMS
TIFF and LibTiff Mail List Archive

Thread

2005.05.18 15:38 "[Tiff] Another libtiff+libjpeg problem", by Thom DeCarlo
2005.05.18 16:12 "Re: [Tiff] Another libtiff+libjpeg problem", by Bob Friesenhahn
2005.05.18 16:54 "RE: [Tiff] Another libtiff+libjpeg problem", by Thom DeCarlo
2005.05.18 18:33 "RE: [Tiff] Another libtiff+libjpeg problem", by Bob Friesenhahn
2005.05.18 19:39 "RE: [Tiff] Another libtiff+libjpeg problem", by Thom DeCarlo
2005.05.19 14:59 "Re: [Tiff] Another libtiff+libjpeg problem", by Frank Warmerdam
2005.05.19 23:00 "Re: [Tiff] Another libtiff+libjpeg problem", by Thom DeCarlo
2005.05.20 00:00 "Re: [Tiff] Another libtiff+libjpeg problem", by Frank Warmerdam
2005.05.28 21:07 "Re: [Tiff] Another libtiff+libjpeg problem", by Thom DeCarlo
2005.06.10 18:01 "Re: [Tiff] Another libtiff+libjpeg problem", by Frank Warmerdam
2005.06.10 18:49 "Re: [Tiff] Another libtiff+libjpeg problem", by Bob Friesenhahn
2005.05.25 10:12 "Re[2]: [Tiff] Another libtiff+libjpeg problem", by Jean-Yves Le Ridant
2005.05.26 17:57 "Re: [Tiff] Another libtiff+libjpeg problem", by Andrey Kiselev
2005.06.13 12:40 "Re: [Tiff] Another libtiff+libjpeg problem", by Jean-Yves Le Ridant
2005.06.13 14:06 "Re: [Tiff] Another libtiff+libjpeg problem", by Andrey Kiselev
2005.06.14 10:24 "Re: [Tiff] Another libtiff+libjpeg problem", by Jean-Yves Le Ridant
2005.06.17 08:22 "Re: [Tiff] Another libtiff+libjpeg problem", by Jean-Yves Le Ridant
2005.06.17 16:29 "Re: [Tiff] Another libtiff+libjpeg problem", by Andrey Kiselev

2005.05.19 14:59 "Re: [Tiff] Another libtiff+libjpeg problem", by Frank Warmerdam

I grabbed the cvs for both libraries this morning. Libjpeg compiles and installs properly, but libtiff fails in tiff_jpeg.c as follows:

In my experience, it has been necessary to hand-edit tiff_jpeg.c if the MK1 CVS libjpeg is used. I have no idea how Frank Warmerdam is building the software without doing these edits.

I don't recommend using the CVS libjpeg for anything but research at the moment.

Folks,

Sorry about that. I believe the problem is that the CVS-head of libjpeg is broken. All my work was with the MK1-branch. Try checking that out.

Best regards,

---------------------------------------+--------------------------------------
I set the clouds in motion - turn up   | Frank Warmerdam, warmerdam@pobox.com
light and sound - activate the windows | http://pobox.com/~warmerdam
and watch the world go round - Rush    | Geospatial Programmer for Rent