AWARE SYSTEMS
TIFF and LibTiff Mail List Archive

Thread

2010.08.20 08:16 "[Tiff] TIFFWriteScanline works on Windows and Linux but fails on Mac", by Dennis_Mølhom_Hansen
2010.08.22 02:26 "Re: [Tiff] TIFFWriteScanline works on Windows and Linux but fails on Mac", by Scott Ribe
2010.08.23 07:04 "Re: [Tiff] TIFFWriteScanline works on Windows and Linux but fails on Mac", by Dennis_Mølhom_Hansen
2010.08.23 07:40 "Re: [Tiff] TIFFWriteScanline works on Windows and Linux but fails on Mac", by John
2010.08.23 08:04 "Re: [Tiff] TIFFWriteScanline works on Windows and Linux but fails on Mac", by Dennis_Mølhom_Hansen
2010.08.23 08:18 "Re: [Tiff] TIFFWriteScanline works on Windows and Linux but fails on Mac", by Dennis_Mølhom_Hansen
2010.08.23 10:18 "Re: [Tiff] TIFFWriteScanline works on Windows and Linux but fails on Mac", by Dennis_Mølhom_Hansen
2010.08.23 10:47 "Re: [Tiff] TIFFWriteScanline works on Windows and Linux but fails on Mac", by John
2010.08.23 12:02 "Re: [Tiff] TIFFWriteScanline works on Windows and Linux but fails on Mac", by Juergen Buchmueller
2010.08.23 13:25 "Re: [Tiff] TIFFWriteScanline works on Windows and Linux but fails on Mac", by Dennis_Mølhom_Hansen
2010.08.23 14:17 "Re: [Tiff] TIFFWriteScanline works on Windows and Linux but fails on Mac", by Dennis_Mølhom_Hansen
2010.08.23 14:38 "Re: [Tiff] TIFFWriteScanline works on Windows and Linux but fails on Mac", by Olivier Paquet
2010.08.24 12:31 "Re: [Tiff] TIFFWriteScanline works on Windows and Linux but fails on Mac", by Dennis_Mølhom_Hansen

2010.08.23 13:25 "Re: [Tiff] TIFFWriteScanline works on Windows and Linux but fails on Mac", by Dennis_Mølhom_Hansen

Hi,

The only flag I used for the built was --prefix. I checked the makefile as you mentioned, and the only option I found in my version was --disable-lzw... It seems to be enable by default. I do not see any general compression flag either.

I tried the sample program "tiffcp -c lzw in_uncompressed.tif out_lzw.tif" and I was able to lzw compressed the tif file. So something is working, right now i'm comparing the source codes to find the issue, but so far without much luck...

On Mon, Aug 23, 2010 at 2:02 PM, Juergen Buchmueller <pullmoll@t-online.de> wrote:

On Mon, 23 Aug 2010 12:18:25 +0200

Dennis Mølhom Hansen <molholm@gmail.com> wrote:

Update: any compression seems to fail on mac, only uncompressed work. Any ideas where to look for a cause/solution?

Perhaps the library was built without support for compression? IIRC you can disable the various schemes and the default may even be to build without compression support. You should take a look at the Makefile for the environment flags to set for supporting LZW compression and possibly others. Or was libtiff autoconf'd? I don't remember. In that case use ./configure --help to see the various options.

HTH
Juergen