AWARE SYSTEMS
TIFF and LibTiff Mail List Archive

Thread

2005.05.13 14:37 "[Tiff] Troubles compiling libtiff on Mac OSX 10.4", by Naveen Nathan
2005.05.13 14:55 "Re: [Tiff] Troubles compiling libtiff on Mac OSX 10.4", by Bob Friesenhahn
2005.05.13 20:12 "Re: [Tiff] Troubles compiling libtiff on Mac OSX 10.4", by Naveen Nathan
2005.06.15 18:59 "[Tiff] RE: Troubles compiling libtiff on Mac OSX 10.3", by Chrysanne M.
2005.06.15 20:01 "Re: [Tiff] RE: Troubles compiling libtiff on Mac OSX 10.3", by Bob Friesenhahn

2005.06.15 20:01 "Re: [Tiff] RE: Troubles compiling libtiff on Mac OSX 10.3", by Bob Friesenhahn

This message is a follow-up to a post last month found at the address below:

http://www.asmail.be/msg0054754473.html

I am using a MACOSX 10.3, and I get the same error when I try to run the "make" cmd after configuring.

"ld: Undefined symbols:
_TIFFClientOpen"

It was suggested that the LibTool was the cause because they are able to build it with their own supplied libtool. I'm emailing to ask that for your next release you take a look at the build tools before including them again.

Did you try the unoffical package I put out for anonymous ftp at ftp://ftp.simplesystems.org/pub/outgoing/tiff-3.7.2.tar.gz? This package works for me on 10.4. If it does not work for you, then the problem is a development tool problem.

There is also the issue that the gcc that Apple provided for 10.3 has known bugs which sometimes cause it to not resolve symbols. They did provide a patch for this on their web site, but it seems that shortly after the Tiger release, they ripped everything necessary to support releases prior to Tiger from their web site. Doing so may be a GPL license violation unless the problem is due to non-GPLed code.

Bob
======================================
Bob Friesenhahn
bfriesen@simple.dallas.tx.us, http://www.simplesystems.org/users/bfriesen/
GraphicsMagick Maintainer, http://www.GraphicsMagick.org/